This report is unavailable (400)

QUESTIONS & ANSWERSCategory: WordPressThis report is unavailable (400)
Profile photo of MNannisMNannis asked 5 months ago

Scrolled thru your Q&A and followed suggestions from this bug fix from 2 years ago. Currently running Version 4.9.4. 
Errors & Debug gave me this:

Last Error detected

Last Error: 2016-12-22 16:07:15: exception 'Google_Auth_Exception' with message 'Error refreshing the OAuth2 token, message: '{
  "error" : "invalid_grant"
}'' in /home/daoist2/public_html/dev/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Auth/OAuth2.php:331
Stack trace:
#0 /home/daoist2/public_html/dev/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Auth/OAuth2.php(264): Google_Auth_OAuth2->refreshTokenRequest(Array)
#1 /home/daoist2/public_html/dev/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Auth/OAuth2.php(240): Google_Auth_OAuth2->refreshToken('1/DydrO8UplfMWc...')
#2 /home/daoist2/public_html/dev/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Service/Resource.php(215): Google_Auth_OAuth2->sign(Object(Google_Http_Request))
#3 /home/daoist2/public_html/dev/wp-content/plugins/google-analytics-dashboard-for-wp/tools/src/Google/Service/Analytics.php(1909): Google_Service_Resource->call('get', Array, 'Google_Service_...')
#4 /home/daoist2/public_html/dev/wp-content/plugins/google-analytics-dashboard-for-wp/tools/gapi.php(277): Google_Service_Analytics_DataGa_Resource->get('ga:112134004', '30daysAgo', 'yesterday', 'ga:sessions,ga:...', Array)
#5 /home/daoist2/public_html/dev/wp-content/plugins/google-analytics-dashboard-for-wp/tools/gapi.php(412): GADWP_GAPI_Controller->handle_corereports('112134004', '30daysAgo', 'yesterday', 'ga:sessions,ga:...', Array, 'qr3_783396484')
#6 /home/daoist2/public_html/dev/wp-content/plugins/google-analytics-dashboard-for-wp/tools/gapi.php(832): GADWP_GAPI_Controller->get_bottomstats('112134004', '30daysAgo', 'yesterday', false)
#7 /home/daoist2/public_html/dev/wp-content/plugins/google-analytics-dashboard-for-wp/admin/ajax-actions.php(108): GADWP_GAPI_Controller->get('112134004', 'bottomstats', '30daysAgo', 'yesterday', false)
#8 [internal function]: GADWP_Backend_Ajax->ajax_item_reports('')
#9 /home/daoist2/public_html/dev/wp-includes/plugin.php(496): call_user_func_array(Array, Array)
#10 /home/daoist2/public_html/dev/wp-admin/admin-ajax.php(85): do_action('wp_ajax_gadwp_b...')
#11 {main}

Error Details

Error Details: None

 

any guidance would be most appreciated

1 Answers
Profile photo of Alin MarcuAlin Marcu Staff answered 5 months ago

Hi,
Usually simply clearing the authorization and re-authorizing works. Have you tried it?

Profile photo of MNannisMNannis replied 5 months ago

hadn’t tried it yet. thank you. all set now.